close

Updated: Chase Plane [Now working], FSUIPC, Orbx and Active Sky for P3Dv4 Now Compatible With Prepar3D v4.1

Hifi Technologies Inc Active Sky For P3dv4 As16 P3dv3

Yet another update: FSFX Packages have updated Chase Plane to be compatible. Looks like it was just an issue with the build number.

Update: Despite Chase Plane’s release notes, it’s not -fully- compatible with 4.1 just yet. Smooth scroll and static cameras have been disabled but otherwise it works fine.

With Lockheed Martin releasing Prepar3D v4.1 earlier today, the community are quick to download the new update. Of course, there still needs to be some updates pushed for add-ons that suit a particular sim. It would appear that Lockheed Martin gave developers a lot of time to prepare as some of the most popular add-ons are already compatible with the new update.

FSUIPC was updated a few days ago to be compatible and teams from both FSFX Packages and HiFi Simulations have already pushed out updates for their products. Of course, scenery products and aircraft should also work just fine. For example, we can confirm the PMDG line of products work perfectly fine with P3D v4.1.

As for Orbx products, you can download the DLL from the forums to enable compatibility with ObjectFlow 2 (open beta). You can do it manually at your own risk, but the team are working hard to package it into FTX very soon.

Tags : AircraftHiFi SimulationsORBXPMDGSceneryUpdate
Calum Martin

The author Calum Martin

I have been an avid fan of Flight Sim since the release of ‘2000 and have been developing my love for aviation ever since. Currently working for a UK airline, I have the knowledge and experience to really deliver an excellent aviation community. Although no real life flying experience, I have a good understanding and always learning more and more. | View My Specs

5 Comments

  1. I’d like to add that according to their Facebook page (and to me testing it) TOGA Envtex can be used with 4.1 without any problems.

JOIN THE DISCUSSION

%d bloggers like this: